Cross-site Request Forgery (CSRF) Affecting org.jenkins-ci.plugins:git package, versions [,4.11.4)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGJENKINSCIPLUGINS-2964204

  • published

    31 Jul 2022

  • disclosed

    31 Jul 2022

  • credit

    Unknown

How to fix?

Upgrade org.jenkins-ci.plugins:git to version 4.11.4 or higher.

Overview

org.jenkins-ci.plugins:git is a Git software configuration management for Jenkins.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Exploiting this vulnerability allows attackers to trigger builds of jobs configured to use an attacker-specified Git repository and to cause them to check out an attacker-specified commit.