Cross-site Request Forgery (CSRF) Affecting org.jenkins-ci.plugins:build-publisher package, versions [0,]


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
5.7 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGJENKINSCIPLUGINS-3030483
  • published 22 Sep 2022
  • disclosed 22 Sep 2022
  • credit Wadeck Follonier, CloudBees, Inc.

How to fix?

There is no fixed version for org.jenkins-ci.plugins:build-publisher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). Build-Publisher Plugin 1.22 and earlier allows attackers with Item/Configure permission to create or replace any Additionally, this endpoint does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability that allows attackers to replace any config.xml file on the Jenkins controller file system with an empty file.As of publication of this advisory, there is no fix.