Improper Input Validation Affecting org.jenkins-ci.plugins:build-publisher package, versions [0,]


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGJENKINSCIPLUGINS-3030486
  • published 22 Sep 2022
  • disclosed 22 Sep 2022
  • credit Matt Sicker, CloudBees, Inc.

How to fix?

There is no fixed version for org.jenkins-ci.plugins:build-publisher.

Overview

Affected versions of this package are vulnerable to Improper Input Validation. Build-Publisher Plugin 1.22 and earlier does not perform a permission check in an HTTP endpoint.This allows attackers with Overall/Read permission to obtain names and URLs of Jenkins servers that the plugin is configured to publish builds to, as well as builds pending for publication to those Jenkins servers.As of publication of this advisory, there is no fix.