Protection Mechanism Failure Affecting org.jenkins-ci.plugins:squashtm-publisher package, versions [0,]


0.0
high
0
10

Snyk CVSS

    Attack Complexity Low
    Integrity High

    Threat Intelligence

    EPSS 0.08% (35th percentile)
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGJENKINSCIPLUGINS-3173611
  • published 16 Dec 2022
  • disclosed 24 May 2022
  • credit Daniel Beck

How to fix?

There is no fixed version for org.jenkins-ci.plugins:squashtm-publisher.

Overview

Affected versions of this package are vulnerable to Protection Mechanism Failure such that the agent-to-controller message does not implement any validation of its input, allowing attackers able to control agent processes to replace arbitrary files on the Jenkins controller file system with an attacker-controlled JSON string.