Cryptographic Issues Affecting org.webjars.npm:elliptic package, versions [,6.5.4)


0.0
medium

Snyk CVSS

    Attack Complexity High
    Scope Changed
    Confidentiality High
Expand this section
NVD
6.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGWEBJARSNPM-1069836
  • published 3 Feb 2021
  • disclosed 26 Jan 2021
  • credit Kyle Den Hartog

How to fix?

Upgrade org.webjars.npm:elliptic to version 6.5.4 or higher.

Overview

org.webjars.npm:elliptic is a Fast elliptic-curve cryptography in a plain javascript implementation.

Affected versions of this package are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.