Improper Access Control Affecting org.wildfly:wildfly-ejb3 Open this link in a new tab package, versions [0,]


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGWILDFLY-2807815

  • published

    4 May 2022

  • disclosed

    3 May 2022

  • credit

    Patrick Del Bello

How to fix?

There is no fixed version for org.wildfly:wildfly-ejb3.

Overview

org.wildfly:wildfly-ejb3 is a WildFly Application Server

Affected versions of this package are vulnerable to Improper Access Control when returning an incorrect caller principal under certain heavily concurrent situations when Elytron Security is used. This flaw allows an attacker to gain improper access to information they should not have.

Note: JBoss EAP 7.1 until 7.4 is not affected by default as it comes with Legacy Security enabled out-of-the-box.

References