Information Exposure Affecting org.xwiki.platform:xwiki-platform-oldcore package, versions [,13.10.4) [14.0-rc-1, 14.3-rc-1)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGXWIKIPLATFORM-3019833

  • published

    9 Sep 2022

  • disclosed

    9 Sep 2022

  • credit

    Unknown

How to fix?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to version 13.10.4, 14.3-rc-1 or higher.

Overview

org.xwiki.platform:xwiki-platform-oldcore is a generic wiki platform offering runtime services for applications built on top of it.

Affected versions of this package are vulnerable to Information Exposure as all rights checks that would normally prevent a user from viewing a document on a wiki can be bypassed using the login action and directly specified templates. This exposes title, content and comments of any document and properties of objects, though class and property name must be known.