Information Exposure Affecting apostrophe package, versions <4.33.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.32% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-APOSTROPHE-21700919
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditSantosh Kumar Puppala

Introduced: 20 Oct 2026

NewCVE-2026-113668  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.33.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Information Exposure via an unspecified vector that allows a remote, unauthenticated attacker to read sensitive information. The exact vulnerable function or file is not disclosed in the available source material, and the fix commit does not contain patch changes to application logic that would clarify the attack surface.

CVSS Base Scores

version 4.0
version 3.1