Information Exposure Affecting apostrophe package, versions <4.34.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.44% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-APOSTROPHE-21701474
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditUnknown

Introduced: 20 Oct 2026

NewCVE-2026-112954  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.34.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Information Exposure due to missing publicApiProjection checks in the public REST API’s search and sort query builders. An unauthenticated attacker can craft search queries to identify documents containing specific words in hidden fields, or sort documents by hidden field values to infer sensitive information.

CVSS Base Scores

version 4.0
version 3.1