Insertion of Sensitive Information into Log File Affecting apostrophe package, versions <4.34.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.33% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Insertion of Sensitive Information into Log File vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHE-21702626
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditUnknown

Introduced: 20 Oct 2026

NewCVE-2026-112952  (opens in a new tab)
CWE-532  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.34.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Insertion of Sensitive Information into Log File due to missing permission and visibility checks in the POST /api/v1/@apostrophecms/doc/slugTaken endpoint. An authenticated attacker, including a user with the editor role, can submit candidate slugs and use the boolean responses to determine whether private pages, drafts, archived content, or admin-only content exist. This allows the attacker to enumerate content they are not authorized to view and map the CMS’s content structure.

CVSS Base Scores

version 4.0
version 3.1