Missing Authorization Affecting apostrophe package, versions <4.34.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.31% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Missing Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHE-21707277
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditUnknown

Introduced: 20 Oct 2026

NewCVE-2026-112957  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.34.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Missing Authorization due to missing authorization checks in the GET /api/v1/@apostrophecms/page/:id endpoint. An authenticated attacker with the editor role who knows or can guess a page’s _id can bypass viewRole restrictions and access the full content of admin-only pages, including sensitive fields restricted by viewPermission.

CVSS Base Scores

version 4.0
version 3.1