Incorrect Authorization Affecting apostrophe package, versions <4.33.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.39% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHE-21707347
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditUnknown

Introduced: 20 Oct 2026

NewCVE-2026-113653  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.33.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Incorrect Authorization because viewRole restrictions are not enforced for unauthenticated users. Applications that create relationships between publicly displayed content and protected types, such as @apostrophecms/user, may expose sensitive information via explicitly enabled public REST APIs or templates that serialize entire related objects. Password hashes are not affected, as they are stored in a separate collection.

CVSS Base Scores

version 4.0
version 3.1