Allocation of Resources Without Limits or Throttling Affecting apostrophe package, versions <4.33.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.62% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Allocation of Resources Without Limits or Throttling vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHE-21707359
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditUnknown

Introduced: 20 Oct 2026

NewCVE-2026-113658  (opens in a new tab)
CWE-770  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.33.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Allocation of Resources Without Limits or Throttling due to incomplete cleanup of rejected uploads in the POST /api/v1/@apostrophecms/rich-text-widget/generate-csv-table endpoint.

CVSS Base Scores

version 4.0
version 3.1