Authorization Bypass Through User-Controlled Key Affecting apostrophe package, versions <4.33.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Authorization Bypass Through User-Controlled Key vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHE-21707366
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditmanus-pi

Introduced: 20 Oct 2026

NewCVE-2026-113655  (opens in a new tab)
CWE-639  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.33.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Authorization Bypass Through User-Controlled Key in the @apostrophecms/page module’s move() function when reordering pages within the same parent. An authenticated editor who can edit a page already nested under a restricted parent can reposition it without authorization on that parent. This operation also updates the ranks of restricted sibling pages without checking their permissions, allowing the attacker to persistently alter their ordering. This issue results from an incomplete fix for CVE-2026-63669, which addressed only moves between different parents.

CVSS Base Scores

version 4.0
version 3.1