Authorization Bypass Through User-Controlled Key Affecting apostrophe package, versions <4.33.0


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.28% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Authorization Bypass Through User-Controlled Key vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHE-21708310
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditUnknown

Introduced: 20 Oct 2026

NewCVE-2026-113665  (opens in a new tab)
CWE-639  (opens in a new tab)

How to fix?

Upgrade apostrophe to version 4.33.0 or higher.

Overview

apostrophe is a content management system (CMS) for Node.js. It supports in-context editing, schema-driven content types, flexible widgets and a great deal more. This module contains everything necessary to build a website with ApostropheCMS.

Affected versions of this package are vulnerable to Authorization Bypass Through User-Controlled Key due to absent authentication and ownership checks in the notification module’s PATCH and DELETE endpoints. An unauthenticated attacker who obtains a valid notification ID can mark another user’s notification as dismissed or permanently delete it, potentially suppressing security-related or administrative notifications.

CVSS Base Scores

version 4.0
version 3.1