Server-side Request Forgery (SSRF) Affecting @apostrophecms/ai-helper package, versions >=1.0.0-beta.10 <1.0.0-beta.13


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.33% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Server-side Request Forgery (SSRF) vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-APOSTROPHECMSAIHELPER-21691381
  • published24 Oct 2026
  • disclosed20 Oct 2026
  • creditmanus-pi

Introduced: 20 Oct 2026

NewCVE-2026-113671  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade @apostrophecms/ai-helper to version 1.0.0-beta.13 or higher.

Overview

@apostrophecms/ai-helper is an AI helpers for content creation

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via an unspecified code path in the AI helper integration, an authenticated attacker can read data they are not authorized to access, resulting in unauthorized disclosure of confidential information.

CVSS Base Scores

version 4.0
version 3.1