Improper Validation of Specified Quantity in Input Affecting @apostrophecms/db-connect package, versions <1.1.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-APOSTROPHECMSDBCONNECT-21708418
  • published25 Oct 2026
  • disclosed20 Oct 2026
  • creditDaniel Coles

Introduced: 20 Oct 2026

NewCVE-2026-113666  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade @apostrophecms/db-connect to version 1.1.0 or higher.

Overview

@apostrophecms/db-connect is a Database connection library and dump/restore tools for ApostropheCMS

Affected versions of this package are vulnerable to Improper Validation of Specified Quantity in Input due to insufficient validation of dotted field paths in the unsetNestedField() helper. An authenticated attacker with view-draft permission, or any logged-in user when guestApiAccess is enabled, can submit a crafted exclusion projection to a piece-type REST endpoint to delete shared prototype methods. This disrupts request handling for all users and tenants in the affected Node.js process until it is restarted.

Note: The issue affects deployments using the SQLite, PostgreSQL, or multipostgres adapters; the default MongoDB adapter is not affected.

CVSS Base Scores

version 4.0
version 3.1