Insecure Encryption Affecting bcrypt package, versions <5.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-BCRYPT-572911
  • published 1 Jul 2020
  • disclosed 21 Jun 2020
  • credit pool683

How to fix?

Upgrade bcrypt to version 5.0.0 or higher.

Overview

bcrypt is an A library to help you hash passwords.

Affected versions of this package are vulnerable to Insecure Encryption. Data is truncated wrong when its length is greater than 255 bytes.