Cryptographic Issues Affecting bcrypt package, versions <5.0.0


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-BCRYPT-575033

  • published

    1 Jul 2020

  • disclosed

    13 Jan 2020

  • credit

    Felix

Introduced: 13 Jan 2020

CWE-310 Open this link in a new tab
First added by Snyk

How to fix?

Upgrade bcrypt to version 5.0.0 or higher.

Overview

bcrypt is an A library to help you hash passwords.

Affected versions of this package are vulnerable to Cryptographic Issues. When hashing a password containing an ASCII NUL character, that character acts as the string terminator. Any following characters are ignored.

References