Insecure Default Initialization of Resource Affecting better-auth package, versions <1.6.11


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.24% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-BETTERAUTH-17889826
  • published8 Jul 2026
  • disclosed7 Jul 2026
  • creditsubhan umer

Introduced: 7 Jul 2026

CVE-2026-67336  (opens in a new tab)
CWE-1188  (opens in a new tab)
CWE-327  (opens in a new tab)
CWE-757  (opens in a new tab)

How to fix?

Upgrade better-auth to version 1.6.11 or higher.

Overview

better-auth is a The most comprehensive authentication library for TypeScript.

Affected versions of this package are vulnerable to Insecure Default Initialization of Resource in the oidcProvider. An attacker can gain unauthorized access or impersonate users by exploiting insecure cryptographic defaults, such as the acceptance of unsigned tokens and the use of weak PKCE methods.

Note: This is only exploitable if the application enables the legacy plugins and the relying parties do not pin to a specific signing algorithm or if the authorization URL is exposed to parties other than the user agent and the application's OP.

Workaround

This vulnerability can be mitigated by explicitly disabling plain PKCE by setting oidcProvider({ allowPlainCodeChallengeMethod: false }) and overriding the metadata to remove "none" from id_token_signing_alg_values_supported.

CVSS Base Scores

version 4.0
version 3.1