Origin Validation Error Affecting better-auth package, versions <1.7.16>=1.8.0-beta.0 <1.8.0-beta.5


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.2% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-BETTERAUTH-22193072
  • published4 Nov 2026
  • disclosed4 Nov 2026
  • creditUnknown

Introduced: 4 Nov 2026

NewCVE-2026-121802  (opens in a new tab)
CWE-346  (opens in a new tab)

How to fix?

Upgrade better-auth to version 1.7.16, 1.8.0-beta.5 or higher.

Overview

better-auth is a The most comprehensive authentication library for TypeScript.

Affected versions of this package are vulnerable to Origin Validation Error via the expo() plugin's public authorization-proxy endpoint, which signs a caller-supplied state value with the application secret without verifying that the server had previously issued that value. Because the same HMAC-SHA256 secret is used for email verification links and the session cookie cache, an attacker can forge an email-change token or a session cookie cache value that Better Auth accepts as legitimate. This allows an unauthenticated attacker who knows a target user's email address to take over the account and change its email address, and - when the session cookie cache is enabled - an attacker who knows a user's ID to act as that user.

Note: The session cookie cache attack vector is only exploitable when the session cookie cache feature is explicitly enabled.

CVSS Base Scores

version 4.0
version 3.1