Improper Authorization Affecting @better-auth/sso package, versions >=1.7.0-rc.2 <1.7.0>=1.7.0 <1.7.3


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-BETTERAUTHSSO-21182274
  • published18 Oct 2026
  • disclosed15 Oct 2026
  • creditmanus-use

Introduced: 15 Oct 2026

NewCVE-2026-110863  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade @better-auth/sso to version 1.7.0, 1.7.3 or higher.

Overview

@better-auth/sso is a SSO plugin for Better Auth

Affected versions of this package are vulnerable to Improper Authorization via the deleteSSOProvider route handler, which previously did not receive the options context required to enforce provider lifecycle guards. An authenticated attacker can delete SSO providers they do not own or are not authorized to manage by sending a delete request without the mutation guard being applied, leading to unauthorized modification of identity provider configurations.

References

CVSS Base Scores

version 4.0
version 3.1