Improper Verification of Cryptographic Signature Affecting browserify-sign package, versions >=2.6.0 <4.2.2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High

    Threat Intelligence

    EPSS 0.05% (18th percentile)
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-BROWSERIFYSIGN-6037026
  • published 27 Oct 2023
  • disclosed 26 Oct 2023
  • credit Bing Shi

How to fix?

Upgrade browserify-sign to version 4.2.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature in the dsaVerify function. An attacker can construct signatures that can be successfully verified by any public key, leading to a signature forgery attack. This is achieved by exploiting an upper bound check issue in the checkValue function, which incorrectly checks the upper bound of the passed parameters.

Note: This vulnerability affects all places in the project that involve DSA verification of user-input signatures.

References