Missing Cryptographic Step Affecting cassproject Open this link in a new tab package, versions <1.5.8


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-CASSPROJECT-2838967

  • published

    19 May 2022

  • disclosed

    19 May 2022

  • credit

    Unknown

How to fix?

Upgrade cassproject to version 1.5.8 or higher.

Overview

cassproject is a Competency and Skills Service

Affected versions of this package are vulnerable to Missing Cryptographic Step when storing cryptographic keys. Exploiting this vulnerability allows a server administrator access to an account’s cryptographic keys.

Notes:

  1. This affects CaSS servers using standalone username/password authentication, which uses a method that expects e2e cryptographic security of authorization credentials.

  2. The vulnerable accounts are only resecured when the user next logs in using standalone authentication after upgrading.