Cross-site Scripting (XSS) Affecting @ckeditor/ckeditor5-engine package, versions >=45.0.0 <47.7.4>=48.0.0 <48.5.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.5% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Cross-site Scripting (XSS) vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-CKEDITORCKEDITOR5ENGINE-21756845
  • published27 Oct 2026
  • disclosed27 Oct 2026
  • creditUnknown

Introduced: 27 Oct 2026

NewCVE-2026-116688  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade @ckeditor/ckeditor5-engine to version 47.7.4, 48.5.1 or higher.

Overview

@ckeditor/ckeditor5-engine is a The editing engine of CKEditor 5 – the best browser-based rich text editor.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). via the _checkShouldRenderAttribute method in domconverter.ts, where the sanitization regex used to strip whitespace before checking for dangerous URI schemes (such as javascript: or data:image/svg) fails to account for null bytes and other control characters (U+0000–U+0020). An authenticated attacker can inject a payload containing these characters to bypass the filter and execute arbitrary JavaScript in the victim's browser.

CVSS Base Scores

version 4.0
version 3.1