Improper Authentication Affecting electerm package, versions <1.3.28


0.0
high

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-ELECTERM-3244397
  • published 22 Jan 2023
  • disclosed 22 Jan 2023
  • credit weinull

How to fix?

Upgrade electerm to version 1.3.28 or higher.

Overview

electerm is an open-sourced terminal/ssh/telnet/serialport/sftp client

Affected versions of this package are vulnerable to Improper Authentication which could allow attackers to execute code on the target system.