Improper Input Validation Affecting electron package, versions <9.4.0 >=10.0.0 <10.1.7



    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.13% (47th percentile)
Expand this section
8.8 high
Expand this section
Red Hat
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-ELECTRON-1049323
  • published 19 Nov 2020
  • disclosed 17 Nov 2020
  • credit Unknown

How to fix?

Upgrade electron to version 9.4.0, 10.1.7 or higher.


electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. An insufficient data validation flaw was found in the WASM component of the Chromium browser.