Use After Free Affecting electron Open this link in a new tab package, versions <9.4.2 >=10.0.0 <10.3.1 >=11.0.0 <11.2.2


0.0
medium
  • Attack Complexity

    High

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-1070015

  • published

    3 Feb 2021

  • disclosed

    3 Feb 2021

  • credit

    Unknown

How to fix?

Upgrade electron to version 9.4.2, 10.3.1, 11.2.2 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Blink component in chromium.