Improper Input Validation Affecting electron package, versions <10.4.2 >=11.0.0 <11.4.1


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-1086695

  • published

    25 Mar 2021

  • disclosed

    18 Mar 2021

  • credit

    Unknown

How to fix?

Upgrade electron to version 10.4.2, 11.4.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. It allowed a remote attacker to leak cross-origin data via a crafted HTML page.