Out-of-bounds Write Affecting electron package, versions <10.4.1 >=11.0.0 <11.4.1


0.0
high

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-ELECTRON-1088600
  • published 25 Mar 2021
  • disclosed 24 Mar 2021
  • credit Alison Huffman

How to fix?

Upgrade electron to version 10.4.1, 11.4.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds Write via a data race in the audio component. A remote attacker could potentially exploit heap corruption using a crafted HTML page.