Out-of-bounds Affecting electron Open this link in a new tab package, versions >=11.0.0 <11.4.4 <10.4.4 >=12.0.0 <12.0.6


0.0
critical
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-1257943

  • published

    28 Apr 2021

  • disclosed

    26 Apr 2021

  • credit

    Brendon Tiszka (@btiszka)

How to fix?

Upgrade electron to version 11.4.4, 10.4.4, 12.0.6 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Out-of-bounds via the V8 component in Chrome.