Improper Input Validation Affecting electron package, versions <10.4.4 >=12.0.0 <12.0.6


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-1277526

  • published

    2 May 2021

  • disclosed

    29 Apr 2021

  • credit

    Sergei Glazunov

How to fix?

Upgrade electron to version 10.4.4, 12.0.6 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation due to insufficient data validation that exists in V8.