Use After Free Affecting electron Open this link in a new tab package, versions <2.0.18 >=3.0.0 <3.0.16 >=3.0.0 <3.1.6 >=4.0.0 <4.0.8


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-174045

  • published

    31 Mar 2019

  • disclosed

    7 Mar 2019

  • credit

    Unknown

How to fix?

Upgrade electron to version 2.0.18, 3.0.16, 3.1.6, 4.0.8 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free via the Chromium FileReader.

Note: This vulnerability affects all software based on Chromium, including Electron.