Use After Free Affecting electron package, versions >=14.0.0 <14.2.8>=15.0.0 <15.4.2>=16.0.0 <16.2.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.9% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-ELECTRON-2441711
  • published6 Apr 2022
  • disclosed21 Mar 2022
  • creditSeongHwan Park

Introduced: 21 Mar 2022

CVE-2022-0975  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade electron to version 14.2.8, 15.4.2, 16.2.0 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in ANGLE.

CVSS Base Scores

version 3.1