Type Confusion Affecting electron Open this link in a new tab package, versions <15.5.3 >=16.0.0 <16.2.3 >=17.0.0 <17.4.1


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-2806357

  • published

    12 May 2022

  • disclosed

    1 May 2022

  • credit

    Man Yue

How to fix?

Upgrade electron to version 15.5.3, 16.2.3, 17.4.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Type Confusion in V8.