Inappropriate implementation Affecting electron package, versions <15.5.4 >=16.0.0 <16.2.3 >=17.0.0 <17.4.1


0.0
medium

Snyk CVSS

    Attack Complexity High

    Threat Intelligence

    EPSS 0.17% (55th percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-ELECTRON-2812499
  • published 9 May 2022
  • disclosed 8 May 2022
  • credit Unknown

How to fix?

Upgrade electron to version 15.5.4, 16.2.3, 17.4.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Inappropriate implementation in Web Cursor.