Improper Input Validation Affecting electron Open this link in a new tab package, versions <15.5.0 >=16.0.0 <16.2.0 >17.0.0 <17.2.0 >=18.0.0-beta.1 <18.0.0


0.0
medium
  • Attack Complexity

    High

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-2869408

  • published

    14 Jun 2022

  • disclosed

    14 Jun 2022

  • credit

    Unknown

How to fix?

Upgrade electron to version 15.5.0, 16.2.0, 17.2.0, 18.0.0 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation which allows attackers who have control over a given app's update server or update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components.