Exposure of Resource to Wrong Sphere Affecting electron Open this link in a new tab package, versions <15.5.6 >=16.0.0 <16.2.6 >=17.0.0 <17.2.0 >=18.0.0-beta.1 <18.0.0


0.0
medium
  • Attack Complexity

    High

  • Privileges Required

    High

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-2869410

  • published

    14 Jun 2022

  • disclosed

    14 Jun 2022

  • credit

    TheGrandPew, msrkp

How to fix?

Upgrade electron to version 15.5.6, 16.2.6, 17.2.0, 18.0.0 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Exposure of Resource to Wrong Sphere which allows a renderer with JS execution to obtain access to a new renderer process even without nodeIntegrationInSubFrames being enabled, that allows effective access to ipcRenderer.