Arbitrary Code Execution Affecting electron Open this link in a new tab package, versions <2.0.17 >=3.0.0 <3.0.15 >=3.1.0 <3.1.3 >=4.0.0 <4.0.4 >=5.0.0-beta.1 <5.0.0-beta.2


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-483050

  • published

    11 Nov 2019

  • disclosed

    31 Jan 2019

  • credit

    PalmerAL

Introduced: 31 Jan 2019

CWE-1188 Open this link in a new tab

How to fix?

Upgrade electron to version 2.0.17, 3.0.15, 3.1.3, 4.0.4, 5.0.0-beta.2 or higher.

If for some reason you are unable to upgrade your Electron version, you can mitigate this issue by disabling all child web contents: view.webContents.on('-add-new-contents', e => e.preventDefault());

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Arbitrary Code Execution. Opening a BrowserView with sandbox: true or nativeWindowOpen: true and nodeIntegration: false results in a webContents where window.open() can be called and the newly opened child will have nodeIntegration enabled.