Use After Free Affecting electron Open this link in a new tab package, versions <6.1.10 >=7.0.0 <7.2.2 >=8.0.0 <8.2.1


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-564272

  • published

    2 Apr 2020

  • disclosed

    2 Apr 2020

  • credit

    Semmle Security Research

How to fix?

Upgrade electron to version 6.1.10, 7.2.2, 8.2.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. Multiple user after free vulnerabilities exists in the WebAudio component of chromium.