Use After Free Affecting electron Open this link in a new tab package, versions <6.1.10 >=7.0.0 <7.2.2 >=8.0.0-beta.1 <8.2.0


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-ELECTRON-565490

  • published

    15 Apr 2020

  • disclosed

    8 Apr 2020

  • credit

    Unknown

Introduced: 8 Apr 2020

CWE-416 Open this link in a new tab

How to fix?

Upgrade electron to version 6.1.10, 7.2.2, 8.2.0 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. FileChooserImpl can outlive ListenerProxy leading to a crash.