Use After Free Affecting electron package, versions >=6.0.0 <6.1.12>=7.0.0 <7.3.0


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.27% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-ELECTRON-569109
  • published17 Apr 2020
  • disclosed17 Apr 2020
  • creditLeecraso and Guang Gong of Alpha Lab, Qihoo 360

Introduced: 17 Apr 2020

CVE-2020-6457  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade electron to version 6.1.12, 7.3.0 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. A Use after free vulnerability exists in unknown areas of the speech recognizer component.

CVSS Base Scores

version 3.1