Use After Free Affecting electron package, versions >=6.0.0 <6.1.12>=7.0.0 <7.3.0>=8.0.0 <8.3.0


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.1% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-ELECTRON-569114
  • published15 May 2020
  • disclosed27 Mar 2020
  • creditZhe Jin from cdsrc of Qihoo 360

Introduced: 27 Mar 2020

CVE-2020-6459  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade electron to version 6.1.12, 7.3.0, 8.3.0 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in payments

CVSS Base Scores

version 3.1