Use After Free Affecting electron package, versions >=7.0.0 <7.3.3>=8.0.0 <8.5.1>=9.0.0 <9.2.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
1.29% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-ELECTRON-598894
  • published29 Jul 2020
  • disclosed9 Jul 2020
  • creditUnknown

Introduced: 9 Jul 2020

CVE-2020-6532  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade electron to version 7.3.3, 8.5.1, 9.2.1 or higher.

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free in SCTP.

CVSS Base Scores

version 3.1