Interpretation Conflict Affecting @fastify/express package, versions >=4.0.5 <4.0.9


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.37% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-FASTIFYEXPRESS-21755407
  • published27 Oct 2026
  • disclosed27 Oct 2026
  • creditAjith Prabhu

Introduced: 27 Oct 2026

NewCVE-2026-112362  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade @fastify/express to version 4.0.9 or higher.

Overview

@fastify/express is an Express compatibility layer for Fastify

Affected versions of this package are vulnerable to Interpretation Conflict via the normalizeUrl function in index.js when the non-default ignoreDuplicateSlashes option is enabled. When an absolute-form request target (e.g. http://host/path) is processed, duplicate-slash normalization collapses the separator after the scheme, causing Fastify's router to resolve the request to a scoped path and execute the handler while the Express middleware layer no longer sees that path. An unauthenticated attacker can exploit this discrepancy to bypass path-scoped Express middleware, including authentication and authorization layers, achieving unauthorized access to protected resources.

Note: This is only exploitable when the non-default ignoreDuplicateSlashes option is explicitly enabled.

CVSS Base Scores

version 4.0
version 3.1