Improper Certificate Validation Affecting faye package, versions <1.4.0



    Attack Complexity High
    User Interaction Required
    Scope Changed
    Confidentiality High
    Integrity High

    Threat Intelligence

    EPSS 0.12% (45th percentile)
Expand this section
8.7 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-FAYE-5497078
  • published 4 May 2023
  • disclosed 4 May 2023
  • credit Unknown

How to fix?

Upgrade faye to version 1.4.0 or higher.


faye is a simple pub/sub messaging for the web.

Affected versions of this package are vulnerable to Improper Certificate Validation due to not implementing certificate verification by default, meaning that it does not check whether the server presents a valid and trusted TLS certificate for the expected hostname.