Information Exposure Affecting @finastra/nestjs-proxy Open this link in a new tab package, versions >=0.4.0 <0.7.0


0.0
medium
  • Attack Complexity

    Low

  • Privileges Required

    High

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-FINASTRANESTJSPROXY-2928756

  • published

    16 Jun 2022

  • disclosed

    16 Jun 2022

  • credit

    Unknown

How to fix?

Upgrade @finastra/nestjs-proxy to version 0.7.0 or higher.

Overview

@finastra/nestjs-proxy is a NestJS Proxy module

Affected versions of this package are vulnerable to Information Exposure due to exposing authorization headers, potentially including sensitive data such as OAuth bearer access tokens.