Protection Mechanism Failure Affecting flowise-components package, versions <3.1.3


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.62% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-FLOWISECOMPONENTS-21693824
  • published24 Oct 2026
  • disclosed7 Oct 2026
  • creditSkaushik-Qlys

Introduced: 7 Oct 2026

NewCVE-2026-73483  (opens in a new tab)
CWE-693  (opens in a new tab)

How to fix?

Upgrade flowise-components to version 3.1.3 or higher.

Overview

flowise-components is a Flowiseai Components

Affected versions of this package are vulnerable to Protection Mechanism Failure via the vm2/@flowiseai/nodevm JavaScript sandbox in the /api/v1/node-custom-function endpoint. An authenticated attacker can supply attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling.

Note: In versions 3.0.8-3.1.2, exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default.

References

CVSS Base Scores

version 4.0
version 3.1