Information Exposure Affecting follow-redirects package, versions <1.14.8


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
5.9 medium
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-FOLLOWREDIRECTS-2396346
  • published 9 Feb 2022
  • disclosed 9 Feb 2022
  • credit haxatron

How to fix?

Upgrade follow-redirects to version 1.14.8 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure due a leakage of the Authorization header from the same hostname during HTTPS to HTTP redirection. An attacker who can listen in on the wire (or perform a MITM attack) will be able to receive the Authorization header due to the usage of the insecure HTTP protocol which does not verify the hostname the request is sending to.

References